24RCSID(
"$Id: 6046869e53c5da24bace37628b2b191934ce1613 $")
26#include <freeradius-devel/server/client.h>
28#include <freeradius-devel/util/misc.h>
29#include <freeradius-devel/radius/defs.h>
31#define FR_STATS_INIT { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, \
32 { 0, 0, 0, 0, 0, 0, 0, 0 }}
48 if ((
request->listener->type != RAD_LISTEN_NONE) &&
49 (
request->listener->type != RAD_LISTEN_ACCT) &&
50 (
request->listener->type != RAD_LISTEN_AUTH))
return;
57#define INC_AUTH(_x) do { radius_auth_stats._x++;request->client->auth._x++; } while (0)
60#define INC_ACCT(_x) do { radius_acct_stats._x++;request->client->acct._x++; } while (0)
108 switch (
request->packet->code) {
110 if (
request->reply->id == -1) {
119 if (
request->reply->id == -1) {
164 for (i = 0; i < 7; i++) {
static uint8_t request[4]
@ FR_RADIUS_CODE_ACCESS_CHALLENGE
RFC2865 - Access-Challenge.
@ FR_RADIUS_CODE_ACCESS_REQUEST
RFC2865 - Access-Request.
@ FR_RADIUS_CODE_STATUS_SERVER
RFC2865/RFC5997 - Status Server (request)
@ FR_RADIUS_CODE_ACCESS_ACCEPT
RFC2865 - Access-Accept.
@ FR_RADIUS_CODE_ACCOUNTING_RESPONSE
RFC2866 - Accounting-Response.
@ FR_RADIUS_CODE_ACCOUNTING_REQUEST
RFC2866 - Accounting-Request.
@ FR_RADIUS_CODE_ACCESS_REJECT
RFC2865 - Access-Reject.
void fr_stats_bins(fr_stats_t *stats, fr_time_t start, fr_time_t end)
Sort latency times into bins.
void request_stats_final(request_t *request)
fr_stats_t radius_auth_stats
fr_stats_t radius_acct_stats
static fr_time_delta_t fr_time_delta_from_sec(int64_t sec)
static int64_t fr_time_delta_to_usec(fr_time_delta_t delta)
#define fr_time_delta_gteq(_a, _b)
#define fr_time_sub(_a, _b)
Subtract one time from another.
#define fr_time_lt(_a, _b)
A time delta, a difference in time measured in nanoseconds.